Not reading any pressure

GasStop Community GasStop Support Not reading any pressure

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #2806
    Josey
    Participant

    Just received my two gas stop valves. Installed on my camper / trailer. Primed valve but not getting any reading on either valves. One bottle is new today and the 2nd one has only been used a couple of times. Any idea as to why my gas stop is not reading? Thanks in advance.

    #2807
    GasStop
    Forum Admin

    Hi Josey,

    Thank you for reaching out!

    If you could contact our US team directly at info@gasstopusa.com, one of our team will guide you through your installation to problem solve this. Once we have a resolution one of our team will post here so that the whole community can see the resolution.

    Many thanks in advance,

    MJ

    GasStop

    #2808
    Josey
    Participant

    WOW.. service as it should be!! Received two new gas stop valves and after installing I was not getting any readings. Contacted Gas stop and got in touch with Mike. On the first call Mike quickly figured out the issue and sent missing O-rings for the valves. Received the o-rings quickly through the mail, reinstalled valves and they work like they should. Now my wife has peace with the safety gas stop provides. A big thanks to Mike and team. I would definitely recommend gas stop to everyone looking to add safety to  their setup. This issue has been  resolved, quickly, effectively and in a timely matter. Thanks again stop gas.  Lloyd

    #2809
    GasStop
    Forum Admin

    Hi Lloyd,

    This is great to hear, thank you for coming back to us. We are very proud of Mike and his team. They are working 24/7 to keep RVers safe across the USA. I will pass on your kind words.

    Safe travels!

    MJ

    GasStop

Viewing 4 posts - 1 through 4 (of 4 total)